Error 12175

sunmartial
Posts: 775
Joined: 24 Jul 2017, 11:43

Error 12175

Post by sunmartial »

Hi Thomas

I have been running SImsounds seamlessly for many months now. I have Version 3.0 on the main (flying) PC, and version 2.11 on a remote PC. I use the remote one for cabin announcements in the cabin, and the main, flying, one for all the vibrations and cockpit sounds.

As I said, everything has been running smoothly for a long time, then suddenly today, the remote copy says " Error 12175 has occurred". Could you tell me what this is please, and why suddenly it has appeared?

Many thanks!
Sunny
Cyprus

P3D v4.4, Prosim v2.21 (MSFS connect), FSUIPC v5.13, server PC (i9-9900K), 3 projectors, 2 avionics PCs, Windows 10, Open Cockpits modules except MCP and EFIS (from CpFlight), and CFY Throttle v4 Pro.
pandine
Posts: 491
Joined: 31 Dec 2014, 08:45
Location: Germany

Re: Error 12175

Post by pandine »

Hi folks,
there a totally 4 customers hit by this issue. All at the same time. This error code is reported by Windows 7 and says that Windows can’t establish a secure connection to the SimSounds server. I guess that a root certificate is outdated and therefore Windows can’t connect via SSL.
This is not a SimSounds issue and other internet services are affected as well.
So please install the latest Microsoft updates for your system.
Best Regards,
Thomas
http://www.simsounds.de

Image
sunmartial
Posts: 775
Joined: 24 Jul 2017, 11:43

Re: Error 12175

Post by sunmartial »

pandine wrote: 24 Jul 2020, 14:47 Hi folks,
there a totally 4 customers hit by this issue. All at the same time. This error code is reported by Windows 7 and says that Windows can’t establish a secure connection to the SimSounds server. I guess that a root certificate is outdated and therefore Windows can’t connect via SSL.
This is not a SimSounds issue and other internet services are affected as well.
So please install the latest Microsoft updates for your system.
Hi Thomas

I have had Windows update turned off through Group Policy for about 2 years now, so Windows should not have updated or changed anything at all......strange that this issue would appear suddenly. I don't want to update my Windows. There are just too many variables and other things might stop working. For example, there was a problem with the Open Cockpits rudder cards with a specific windows version onwards, so I stayed on the version that worked and then froze all the updates. I cannot take the risk of updating windows. It's a huge operation to test everything, and if there are issues, then it's hard to roll back. Nothing else has stopped working, and I have a whole range of things networked on those two PC's, so it's strange that it is just targetting simsounds.... is there some way around this from your end? I'm sure there must be, for someone as smart as you. ;)

Thanks
Sunny
Cyprus

P3D v4.4, Prosim v2.21 (MSFS connect), FSUIPC v5.13, server PC (i9-9900K), 3 projectors, 2 avionics PCs, Windows 10, Open Cockpits modules except MCP and EFIS (from CpFlight), and CFY Throttle v4 Pro.
oesommer
Posts: 5
Joined: 31 Dec 2010, 03:20

Re: Error 12175

Post by oesommer »

I also got this error message in SimSound on my win7 PC.
I searched a bit on google and found this solution.

https://www.qunect.com/appnotes/tls.html

Following the instructions on this page and running the file that it refers to solved my problem.
Hope it does for you others who have also got this problem.

Best Regards
Øyvin
SAS031
pandine
Posts: 491
Joined: 31 Dec 2014, 08:45
Location: Germany

Re: Error 12175

Post by pandine »

As I said: A root certificate on your PC is out of date now. Each certificate has a limited time of life. And now some SSL server certificates can’t be validated any more. More and more will follow during the next month.
Best Regards,
Thomas
http://www.simsounds.de

Image
pandine
Posts: 491
Joined: 31 Dec 2014, 08:45
Location: Germany

Re: Error 12175

Post by pandine »

oesommer wrote: 25 Jul 2020, 17:04 I also got this error message in SimSound on my win7 PC.
I searched a bit on google and found this solution.

https://www.qunect.com/appnotes/tls.html

Following the instructions on this page and running the file that it refers to solved my problem.
Hope it does for you others who have also got this problem.

Best Regards
Øyvin
SAS031
Thank you!
Best Regards,
Thomas
http://www.simsounds.de

Image
pandine
Posts: 491
Joined: 31 Dec 2014, 08:45
Location: Germany

Re: Error 12175

Post by pandine »

Last edited by pandine on 28 Jul 2020, 13:18, edited 2 times in total.
Best Regards,
Thomas
http://www.simsounds.de

Image
sunmartial
Posts: 775
Joined: 24 Jul 2017, 11:43

Re: Error 12175

Post by sunmartial »

oesommer wrote: 25 Jul 2020, 17:04 I also got this error message in SimSound on my win7 PC.
I searched a bit on google and found this solution.

https://www.qunect.com/appnotes/tls.html

Following the instructions on this page and running the file that it refers to solved my problem.
Hope it does for you others who have also got this problem.

Best Regards
Øyvin
SAS031
Thank you Øyvin.
I didn't run Windows Update - just ran that installer file, and SImsounds seems to be working again!

Thanks a lot. :-)
Sunny
Cyprus

P3D v4.4, Prosim v2.21 (MSFS connect), FSUIPC v5.13, server PC (i9-9900K), 3 projectors, 2 avionics PCs, Windows 10, Open Cockpits modules except MCP and EFIS (from CpFlight), and CFY Throttle v4 Pro.
pandine
Posts: 491
Joined: 31 Dec 2014, 08:45
Location: Germany

Re: Error 12175

Post by pandine »

Hi folks,

please follow Øyvin's instructions given here: viewtopic.php?f=127&t=20329#p132524

Once again thank you Øyvin to find this solution. My assumption that an outdated certificate was the reason for that issue was definitely wrong. Sorry folks ...
Best Regards,
Thomas
http://www.simsounds.de

Image
Pete Dowson
Posts: 768
Joined: 15 Oct 2014, 00:32

Re: Error 12175

Post by Pete Dowson »

pandine wrote: 24 Jul 2020, 14:47 there a totally 4 customers hit by this issue. All at the same time. This error code is reported by Windows 7 and says that Windows can’t establish a secure connection to the SimSounds server. I guess that a root certificate is outdated and therefore Windows can’t connect via SSL.
This is not a SimSounds issue and other internet services are affected as well.
So please install the latest Microsoft updates for your system.
Make that 5 customers.

It is a Windows 7 networked PC, but I've had no Windows updates for a long time. I think I stopped them. Are they still available for Windows 7?

I'm very reluctant to try Windows updates on this PC as everything else is working splendidly. guess i will have to do without SimSounds on this PC. (The important one is the one on the same PC as P3d5 which provides extra aircraft-related sounds).

BTW other programs using sound on the affected PC are working okay -- ProsimAudio and Pilot2ATC.

Best Regards
Pete Dowson
My System

Win10: 2004 build 19041.685
Processor: I9 9900KS at 5.5GHz
Mobo: Maximus XI Extreme Z390
Memory: 32Gb at 3900 MHz.
GPU: RTX 24Gb Titan
Displays: 2 x 2160p projectors at 30Hz onto 200 FOV curved screen
P3D5 set with 2 windows using ViewGroups
Post Reply

Return to “SimSounds - by Pandine”