Page 1 of 1

A320 Trim wheel unstable

Posted: 07 Jul 2020, 15:15
by FaustoP

Months ago (approximately when switching from ProsimA320 v1.30 to v1.31) I started to experience this problem with the trim wheel moving with large excursion and doing some sort of overcontrol which makes it impossible to settle in the correct position. ... 0.mp4?dl=0

The manufacturer says it's something on the software side (something I changed) but I tried the followings:
1) Reverting to the previous Prosim version
2) Restoring the machine from a previous backup
3) try with another pc with a clean FSX/Prosim installation with no additional software installed
4) recalibrate the trim wheel in ProsimA320
5) last but not least: ensure there's no trim wheel mapping in P3D

...and still I get the problem.

by comparing the config.xml I had before updating and the one which was rewritten after updating to V1.31 I noticed that there's a new "ANALOG" information
<mapping connection="Elevator trim input">
<poldragonet serial="axes" port="4" type="ANALOG">
whereas the previous version was:
<mapping connection="Elevator trim input">
<poldragonet serial="axes" port="4">
Can you give any suggestion (especially on the "ANALOG" type introduced in V1.31) which could help in understanding the issue?

Thanks in advance for your support,

Best Regards

Re: A320 Trim wheel unstable

Posted: 13 Aug 2020, 04:34
by FaustoP

Just for updating everyone who reads and/or could experience a similar problem in the future.

It was hardware related.

The trim wheel motor eventually got physically disconnected from the gears (now you can hear the motor noise but there’s no traction on the trim wheel anymore. The wheel is now also stuck in the range +1.5/+3 (which also makes the plane not easy to fly, as I have to takeoff while still pushing the stick halfway forward).

I don’t know the exact cause as the sim is still within warranty period and I didn’t open the TQ for diagnosing.

Anyway I managed to get a spare TQ, installed it and it worked fine straight away.

No software related issues therefore.

Hope this will help someone in the future.

All the best,